your PHP version (○○) does not satisfy that requirement と出たときのエックスサーバーでの対処

Laravelデバック対策

エックスサーバーにSSHでアクセスして composer installを実行した時、次のようなエラーになることがあります。

Your requirements could not be resolved to an installable set of packages.
Problem 1
– △△△ requires php ^7.4 || ^8.0 -> your PHP version (7.3.16) does not satisfy that requirement.

次のような意味です。

「△△△は php ^7.4 || ^8.0 が必要です。あなたのPHP (7.3.16) はこの規定を満たしていません。」

とりあえず今だけphpのバージョン変えたい!という場合の対策を紹介します。

普段使うphpバージョンを変えたい場合は、こちらの記事をどうぞ。

your PHP version (○○) does not satisfy that requirement と出たときのエックスサーバーでの対処

①PHPバージョンチェック

まず、現在のPHPバージョンを確認して、「本当に言われていることが合っているのかな?」というのをチェックしておきましょう。

②composerの場所チェック

バージョンアップが必要な場合は、まず、composerの場所を調べます。そのためのコマンドはこちら。

わたしの場合は、コードを打つと、下記のように戻ってきます。

③PHPバージョンアップ

PHPのバージョンを指定して composer installを行うには、次のようにコマンドをいれます。

PHP【バージョン】 【composerの場所】 install

わたしの場合は、PHPを7.4を使いたい、さらに、composerの場所は /usr/bin/composer なので、次のようにコマンドをいれます。

この後、composer installが実行されます。

コメント

タイトルとURLをコピーしました